Paul Roub

blah blah blahg

.so Hell

So I’m trying to install a Subversion server, but I’m trapped in .so / RPM hell. The big sticking point: Subversion depends on Apache 2.x, and in particular the recent Subversion builds want httpd v2.0.48 or later. I, of course, have 2.0.40 installed.

So in attempting to install the latest apache (from source RPMs at the moment, but the results are the same via binary), I find that it insists on libdb-4.1.so. Now, I do have that on the system, but it’s not my current RPM install – that is, I have a source-build libdb 4.1 alongside an RPMed 4.0.14 . I’d upgrade that, but a number of other things depend on it. To wit:

    libdb-4.0.so is needed by (installed) python-2.2.2-26
    libdb-4.0.so is needed by (installed) pam-0.75-48
    libdb-4.0.so is needed by (installed) webalizer-2.01_10-11
    libdb-4.0.so is needed by (installed) cyrus-sasl-2.1.10-4
    libdb-4.0.so is needed by (installed) perl-5.8.0-88.3
    libdb-4.0.so is needed by (installed) sendmail-8.12.8-9.90
    libdb-4.0.so is needed by (installed) perl-DB_File-1.804-88.3
    libdb-4.0.so is needed by (installed) drac-1.11-1
    libdb-4.0.so is needed by (installed) apr-util-0.9.5-0.1
    libdb-4.0.so is needed by (installed) subversion-1.0.6-1
    libdb-4.0.so is needed by (installed) httpd-2.0.40-21.11

Some of which I’d need to uninstall, just so I can reinstall the dependencies, then reinstall apache, etc.

Is there a most-sensible way (read: least painful) way to get this straightened out?

And yeah, I know, Debian. But I didn’t get to choose the distribution, so here we are.

Oh, and that older SVN? Not working properly, possibly due to the fun db4 setup.